Icon
DragThing 5.9.12
Released 8th October 2013

50

DragThing 5.9.12 adds support for Mavericks. The list of changes is here.

DragThing now requires Mac OS X 10.7.4 or later - if you are still running an earlier version of Mac OS, please download an older version instead.

This is a free upgrade for existing DragThing 5 users. If you want to help support all the work we've done over the years, and have bought your copy of DragThing already, why not consider buying a copy of our advanced scientific calculator PCalc for Mac OS X or the iPhone? Thanks!